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Overview 
The estimated time to complete this lab is 20 minutes. 

In this lab, you will complete the following tasks: 

1. Publish a Power BI Desktop Dataset & Report to the Power BI service 

2. Download, Install, and Use Analyze in Excel  

3. Build an Excel Report using a Power BI Dataset 

 

NOTE:  This lab has been created based on the sales activities of the fictitious Wi-Fi company called 

SureWi which has been provided by P3 https://powerpivotpro.com/.  The data is property of P3 and 

has been shared with the purpose of demonstrating Excel and Power BI functionality with industry 

sample data.  Any use of this data must include this attribution to P3. 

 

https://powerpivotpro.com/


 

 

Power BI Modern Excel Analyst in a day: Lab 03A 202101© 2021 Microsoft. All rights reserved. 3 

Exercise 1: Publish a Power BI Desktop 
Dataset & Report to the Power BI service 
In this exercise, you will use Power BI Desktop to publish your Dataset and Report to My workspace in 

the Power BI service. 

Task 1: Launch Power BI Desktop 

In this task, you will launch Power BI Desktop and open a PBIX file. 

1. Launch Power BI Desktop. 

 

2. If applicable, use the “x” in the upper right-hand corner to close the Welcome window. 

Task 2: Open the PBIX file 

In this task, you will navigate and open the starting PBIX file with the Dataset and Report created from 

Lab 02. 

3. Select File > Open report > Browse reports. 

 

4. Navigate to the <CourseFolder>\Attendee\Lab Materials\Lab 03A\ folder. 

5. Select the file “MAIAD Lab 03A – Power BI Model.pbix” and choose Open. 

Task 3: Publish the PBIX file to the Service 

In this task, you will publish the Dataset and Report from the Power BI Desktop file to the Power BI 

service. 

6. First, you will need to sign in to Power BI.  Click on Sign in located in the upper right-hand corner 

of Power BI Desktop. 
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7. Next, you will need to enter your Power BI username and password.  Once signed in, you will 

notice the Sign in changes to become your name. 

 

8. From the Home tab in the main menu, select the Publish button. 

 

9. Select My workspace. 

 

10. Choose the Select button – to publish the data model and report page to the Power BI service. 

Note:  All users have My workspace in Power BI service – this is your personal sandbox.  Every 

organization has different Workspaces.  Workspaces can be created, and users can be added to 

Workspaces to share Datasets and Reports across the organization. 

11. Once the publish is successful, you will see the “Success!” message with a link that you can click to 

open the report in the Power BI service. 
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12. Click on the Open ‘MAIAD Lab 03A – Power BI Model.pbix’ in Power BI link. 

 

After clicking on the link, you will be navigated to your browser where you will see your report 

published to Power BI service in your My workspace location. 

Note:  To navigate directly to Power BI service enter the URL:  https://app.powerbi.com in your 

browser. 

 

Note:  Selected report page, slicers and filters are captured as default settings when published to 

the Power BI service. 

 

https://app.powerbi.com/groups/me/reports/0a9c5249-218c-41d0-b48f-9d66c93f5e52/ReportSection
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Exercise 2: Download, Install, and Use 
Analyze in Excel  
In this exercise, you will download the Analyze in Excel libraries and use Analyze in Excel to connect to 

the published “MAIAD Lab 03A – Power BI Model” in Power BI from within the Excel application. 

Task 1: Download Analyze in Excel updates 

In this task, you will download a one-time download of Excel libraries that enables Excel to connect to 

Power BI Datasets. 

13. From within the Power BI service, select Analyze in Excel updates from the Downloads menu which 

is in the upper right corner. 

 

14. Select the Download button. 
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Task 2: Install Analyze in Excel 

In this task, you will install the Excel libraries that enable Excel to connect to Power BI Datasets. 

15. Once the download completes, the installation file will be in bottom left-hand side of your 

browser. Select the Open menu option on the file to launch the (.msi) installer wizard. 

 

16. Follow the wizard steps to install the Analyze in Excel libraries. 

 

Task 3: Launch Analyze in Excel from Datasets + dataflows 

In this task, you will navigate to the Datasets + dataflows location in the Power BI service to launch 

Analyze in Excel using the “MAIAD Lab 03A – Power BI Model” Dataset. 

17. From the left-hand pane navigation, select My workspace. 
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18. Select the Datasets + dataflows navigation option.  

 

Note:  When you publish your PBIX file to the service, there are two Power BI artifacts created: the 

Data Model will be in Datasets +dataflows and Report Pages will be in Reports. 

19. From the “MAIAD Lab 03A – Power BI Model” Dataset select More options and then choose the 

Analyze in Excel menu option.  
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Task 4: Launch the Analyze in Excel file 

In this task, you will launch the Excel file that has been connected to the “MAIAD Lab 03A – Power BI 

Model” Data Model. 

20. From the bottom left-hand side of your browser, select the Excel file and Open option. 

 

21. Once Excel launches, you may need to click the buttons to Enable Editing and Enable Content. This 

allows Excel to connect to the data model published to the Power BI service, which is an external 

data connection to Microsoft’s Azure storage in the cloud.  

 

Note:  If you are not prompted with both the Enable Editing and Enable Content messages, you 

may need to check your Options > Trust Center > Trust Center Settings… to ensure your Message 

Bar Settings are turned on. 

 



 

 

Power BI Modern Excel Analyst in a day: Lab 03A 202101© 2021 Microsoft. All rights reserved. 10 

Exercise 3: Build an Excel report using a 
Power BI Dataset 
In this exercise, you will create a report in Excel using the Power BI Dataset connected to “MAIAD Lab 

03A – Power BI Model” created using Analyze in Excel. The Excel report will contain a PivotTable, a 

PivotChart and CUBE formulas. 

Task 1: Add Measures to the PivotTable Fields Values 

In this task, you will populate the PivotTable with Measure fields from the Power BI Dataset 

connection. 

22. From the PivotTable Fields window, select the Gear icon and change to the Fields Sectrion and 

Areas Section Side-By-Side option. 

 

Note:  By default, the PivotTable Fields are displayed with the Fields Section and Areas Section 

Stacked.  The instructions that follow have the Pivot Table Fields displayed as Fields Section and 

Areas Section Side-By-Side.   
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23. From the Offices measure table, drag the [# of Offices] measure to the Values section in the 

PivotTable Fields List. 

24. From the Contracts measure table, click the checkbox for the [Total Contracts] & [MRR Won - 

Contracts] measures to the Values section in the PivotTable Fields List. 

 

Note:  When selecting fields from the measure tables, the checkbox will move the field into the 

Values section by default – this is because only measures can go into the Values section of a 

PivotTable Field List when connecting Excel to a Power BI service Dataset. 
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25. Right click on the PivotTable, select the PivotTable Options… 

 

26. Select Display and then de-select the checkbox to Show the Values row. 

 

Note:  This is done for aesthetics purposes to remove the row with “Values” in the heading that 

happens by default when adding more than one measure into the Values section of the PivotTable 

Fields. 
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Task 2: Add Fields to the PivotTable Fields Rows 

In this task, you will populate the PivotTable with Lookup fields from the Power BI Dataset connection. 

27. From the Offices field table, drag the [Region] and [District] columns to the Rows section in the 

PivotTable Fields List. 

 

28. Use the mouse to place the cursor in Cell A1 and type the name “Region & District” into the cell to 

change the default heading name. 

 

Task 3: Insert a PivotChart 

In this task, you will insert a PivotChart workspace into the Excel worksheet to the right of the 

PivotTable.  Then you will add fields to the Axis and Values sections. 
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29. Use your mouse to select Cell E1 on the worksheet – this is the selects the location for the 

PivotChart. 

 

30. Select the Insert tab on the main menu and select the PivotChart option from the PivotChart 

button drop down. 

 

31. On the Create PivotChart window, select the Use an external data source radio button. 

32. Select the Choose Connection… button. 
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33. Then from the Connections tab and the Connections in this Workbook section, select the 

pbiazure//api.powerbi.com connection string path name to connect the PivotChart to the Power BI 

Dataset external data source. 

 

Note:  The exact name of your pbiazure://api.powerbi.com connection string will be different than 

the one shown in the above image.  This is the unique connection location identifier for a 

published Power BI dataset artifact. 

34. Click OK. 

35. From the Quotes measure table, click the checkbox next to the [Won vs Potential MRR] measure to 

move the measure into the Values section in the PivotTable Fields List. 

36. From the Offices field table, drag the [Region] to the Rows section in the PivotTable Fields List. 
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Task 4: Format PivotChart 

In this task, you will format the PivotChart using some of the familiar formatting options in Excel. 

37. From the Design tab in the main menu, select Style 4. 

 

38. Double click into the Chart Title and change the default Title text to MMR Won % by Region. 

39. Use the mouse to hover over the upper right-hand side of the PivotChart to display the Chart 

Elements options and de-select the Legend checkbox – to remove the Legend. 

 

Task 5: Add KPIs using CUBEVALUE 

In this task, you will use CUBE formulas to create high level KPIs for the report. 

40. Use a right-click on row 1 to Insert a row above the PivotTable and PivotChart. 

41. Use CTRL+Y to repeat the last step and add another row above the PivotTable and PivotChart. 

42. Use a right-click on column A to Insert a column before the PivotTable. 

Note:  This provides a row and column buffer for aesthetics purposes. And provides a row for a 

report heading and the KPIs using CUBEVALUE formulas.  
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43. Right-click column A and set the column with to 1. 

44. Use Fill Color = Black from the Home tab on the main menu to create a report heading in row 2. 

45. Use Font Color = Gold, Accent 4 for row 2. 

46. Select Cell I2 and enter the text “Potential MRR:” – this will serve as the KPI description. 

47. In Cell J2 enter the following CUBEVALUE formula and hit Enter: 

=CUBEVALUE("Power BI - MAIAD Lab 03A – Power BI Model","[Measures].[Potential MRR]") 

 

Tip:  As you type the CUBEVALUE formula, you will notice that Intellisense displays to guide you as 

to the syntax needed to complete the formula.  A CUBEVALUE formula can be combined for use 

with Slicers. 

48. Select Cell K2 and enter the text “Won MRR:” – this will serve as the KPI description. 

49. In Cell L2 enter the following CUBEVALUE formula and hit Enter: 

=CUBEVALUE("Power BI - MAIAD Lab 03A – Power BI Model","[Measures].[MRR Won - Contracts]") 

 

 Select Cell M2 and enter the text “% Won:” – this will serve as the KPI description. 
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50. In Cell N2 enter the following Excel formula and hit Enter: 

=L2/J2

 

Tip:  You can combine the familiarity and features of Excel with Dataset published to Power BI! 

51. Using a right-click, select Format Cells… to percentage. 

52. Select File from the Main Excel Ribbon Menu, then Save As. 

53. Navigate to the <CourseFolder>\Attendee\Lab Materials\Lab 03A\ folder. 

54. Save the file as “MAIAD Lab 03A – Power BI Model – My Solution.pbix”. 
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Summary 
In this lab, you published a Power BI Desktop Dataset and Report to the Power BI service.  Then you 

created a report in Excel with a PivotTable, PivotChart and CUBE functions connected to a Power BI 

Dataset.  This final Lab illustrates what is possible when you use Power BI together with Excel. 

 

Important:  Now that you have your report created, you will want to keep it updated.  But do not 

worry, it takes just two button clicks:  Data > Refresh All. 
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Terms of Use 
© 2021 Microsoft. All rights reserved. 

By using this hands-on lab, you agree to the following terms: 

The technology/functionality described in this hands-on lab is provided by Microsoft Corporation in a 

“sandbox” testing environment for purposes of obtaining your feedback and to provide you with a 

learning experience. You may only use the hands-on lab to evaluate such technology features and 

functionality and provide feedback to Microsoft. You may not use it for any other purpose. Without 

written permission, you may not modify, copy, distribute, transmit, display, perform, reproduce, 

publish, license, create derivative works from, transfer, or sell this hands-on lab or any portion thereof. 

COPYING OR REPRODUCTION OF THE HANDS-ON LAB (OR ANY PORTION OF IT) TO ANY OTHER 

SERVER OR LOCATION FOR FURTHER REPRODUCTION OR REDISTRIBUTION WITHOUT WRITTEN 

PERMISSION IS EXPRESSLY PROHIBITED. 

THIS HANDS-ON LAB PROVIDES CERTAIN SOFTWARE TECHNOLOGY/PRODUCT FEATURES AND 

FUNCTIONALITY, INCLUDING POTENTIAL NEW FEATURES AND CONCEPTS, IN A SIMULATED 

ENVIRONMENT WITHOUT COMPLEX SET-UP OR INSTALLATION FOR THE PURPOSE DESCRIBED 

ABOVE. THE TECHNOLOGY/CONCEPTS REPRESENTED IN THIS HANDS-ON LAB MAY NOT REPRESENT 

FULL FEATURE FUNCTIONALITY AND MAY NOT WORK THE WAY A FINAL VERSION MAY WORK. WE 

ALSO MAY NOT RELEASE A FINAL VERSION OF SUCH FEATURES OR CONCEPTS. YOUR EXPERIENCE 

WITH USING SUCH FEATURES AND FUNCITONALITY IN A PHYSICAL ENVIRONMENT MAY ALSO BE 

DIFFERENT. 

FEEDBACK If you give feedback about the technology features, functionality and/or concepts 

described in this hands-on lab to Microsoft, you give to Microsoft, without charge, the right to use, 

share and commercialize your feedback in any way and for any purpose. You also give to third parties, 

without charge, any patent rights needed for their products, technologies and services to use or 

interface with any specific parts of a Microsoft software or service that includes the feedback. You will 

not give feedback that is subject to a license that requires Microsoft to license its software or 

documentation to third parties because we include your feedback in them. These rights survive this 

agreement. 

MICROSOFT CORPORATION HEREBY DISCLAIMS ALL WARRANTIES AND CONDITIONS WITH REGARD 

TO THE HANDS-ON LAB, INCLUDING ALL WARRANTIES AND CONDITIONS OF MERCHANTABILITY, 

WHETHER EXPRESS, IMPLIED OR STATUTORY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND 

NON-INFRINGEMENT. MICROSOFT DOES NOT MAKE ANY ASSURANCES OR REPRESENTATIONS WITH 

REGARD TO THE ACCURACY OF THE RESULTS, OUTPUT THAT DERIVES FROM USE OF THE VIRTUAL 

LAB, OR SUITABILITY OF THE INFORMATION CONTAINED IN THE VIRTUAL LAB FOR ANY PURPOSE. 

DISCLAIMER This lab contains only a portion of new features and enhancements in Microsoft Power 

BI. Some of the features might change in future releases of the product. 


